tAPKBUILD - paraports - parazyd's aports
 (HTM) git clone https://git.parazyd.org/paraports
 (DIR) Log
 (DIR) Files
 (DIR) Refs
 (DIR) README
 (DIR) LICENSE
       ---
       tAPKBUILD (1096B)
       ---
            1 # Maintainer: Ivan J. <parazyd@dyne.org>
            2 pkgname=py-babelfish
            3 _pkgname=babelfish
            4 pkgver=0.5.5
            5 pkgrel=0
            6 pkgdesc="Python library to work with countries and languages"
            7 url="https://github.com/Diaoul/babelfish"
            8 arch="noarch"
            9 license="BSD"
           10 depends=""
           11 makedepends="python2-dev python3-dev py-setuptools"
           12 subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
           13 source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
           14 builddir="$srcdir/$_pkgname-$pkgver"
           15 
           16 build() {
           17         cd "$builddir"
           18 
           19         python2 setup.py build || return 1
           20         python3 setup.py build || return 1
           21 }
           22 
           23 package() {
           24         mkdir -p "$pkgdir"
           25 }
           26 
           27 _py2() {
           28         replaces="$pkgname"
           29         _py python2
           30 }
           31 
           32 _py3() {
           33         _py python3
           34 }
           35 
           36 _py() {
           37         local python="$1"
           38         pkgdesc="$pkgdesc (for $python)"
           39         depends="$depends $python"
           40         install_if="$pkgname=$pkgver-r$pkgrel $python"
           41 
           42         cd "$builddir"
           43         $python setup.py install --prefix=/usr --root="$subpkgdir"
           44 }
           45 
           46 sha512sums="71504dd0203ad85a6a69107d67df3bd5ae4193515e74c05b346a8bd0aab425fc1534d54d1c74b14e48580ee5e76f04705e35c2d359fbe46254bee37e41cb4bfa  babelfish-0.5.5.tar.gz"