tAPKBUILD - paraports - parazyd's aports
 (HTM) git clone https://git.parazyd.org/paraports
 (DIR) Log
 (DIR) Files
 (DIR) Refs
 (DIR) README
 (DIR) LICENSE
       ---
       tAPKBUILD (1128B)
       ---
            1 # Maintainer: Ivan J. <parazyd@dyne.org>
            2 pkgname=py-bjoern
            3 _pkgname=bjoern
            4 pkgver=3.0.1
            5 pkgrel=0
            6 pkgdesc="A screamingly fast Python WSGI server written in C"
            7 url="https://github.com/jonashaag/bjoern"
            8 arch="x86_64"
            9 license="BSD"
           10 depends="http-parser libev"
           11 makedepends="python2-dev python3-dev py-setuptools http-parser-dev libev-dev"
           12 subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
           13 source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
           14 builddir="$srcdir/$_pkgname-$pkgver"
           15 
           16 build() {
           17         cd "$builddir"
           18 
           19         python2 setup.py build || return 1
           20         python3 setup.py build || return 1
           21 }
           22 
           23 package() {
           24         mkdir -p "$pkgdir"
           25 }
           26 
           27 _py2() {
           28         replaces="$pkgname"
           29         _py python2
           30 }
           31 
           32 _py3() {
           33         _py python3
           34 }
           35 
           36 _py() {
           37         local python="$1"
           38         pkgdesc="$pkgdesc (for $python)"
           39         depends="$depends $python"
           40         install_if="$pkgname=$pkgver-r$pkgrel $python"
           41 
           42         cd "$builddir"
           43         $python setup.py install --prefix=/usr --root="$subpkgdir"
           44 }
           45 
           46 sha512sums="7213e237097ce4d7d2b9c5061739ca0b1a54144e48777990f4bc180762712ccad8383efae76d6ce61da954238fef134da76377041a79b7962200826eec63eb16 bjoern-3.0.1.tar.gz"