tAPKBUILD - paraports - parazyd's aports
 (HTM) git clone https://git.parazyd.org/paraports
 (DIR) Log
 (DIR) Files
 (DIR) Refs
 (DIR) README
 (DIR) LICENSE
       ---
       tAPKBUILD (1141B)
       ---
            1 # Maintainer: Ivan J. <parazyd@dyne.org>
            2 pkgname=py-rebulk
            3 _pkgname=rebulk
            4 pkgver=0.9.0
            5 pkgrel=0
            6 pkgdesc="Python library that performs advanced searches in strings"
            7 url="https://github.com/Toilal/rebulk"
            8 arch="noarch"
            9 license="MIT"
           10 _py2_deps="py2-six"
           11 _py3_deps="py3-six"
           12 makedepends="$_py2_deps $_py3_deps python2-dev python3-dev py-setuptools"
           13 subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
           14 source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
           15 builddir="$srcdir/$_pkgname-$pkgver"
           16 
           17 build() {
           18         cd "$builddir"
           19 
           20         python2 setup.py build || return 1
           21         python3 setup.py build || return 1
           22 }
           23 
           24 package() {
           25         mkdir -p "$pkgdir"
           26 }
           27 
           28 _py2() {
           29         replaces="$pkgname"
           30         _py python2
           31 }
           32 
           33 _py3() {
           34         _py python3
           35 }
           36 
           37 _py() {
           38         local python="$1"
           39         pkgdesc="$pkgdesc (for $python)"
           40         depends="$depends $python"
           41         install_if="$pkgname=$pkgver-r$pkgrel $python"
           42 
           43         cd "$builddir"
           44         $python setup.py install --prefix=/usr --root="$subpkgdir"
           45 }
           46 
           47 sha512sums="25a22b3a5f5519f6f8c10abf6a477f212c0500264cfdcc5a9be09d3818462a051b1a7cd78f94991c44ac6bcdc7435b9909e65de48d1bd8138989e0da98d10262  rebulk-0.9.0.tar.gz"