tAPKBUILD - paraports - parazyd's aports
 (HTM) git clone https://git.parazyd.org/paraports
 (DIR) Log
 (DIR) Files
 (DIR) Refs
 (DIR) README
 (DIR) LICENSE
       ---
       tAPKBUILD (1154B)
       ---
            1 # Maintainer: Ivan J. <parazyd@dyne.org>
            2 pkgname=py-stevedore
            3 _pkgname=stevedore
            4 pkgver=1.30.1
            5 pkgrel=0
            6 pkgdesc="Manage dynamic plugins for Python applications"
            7 url="https://github.com/openstack/stevedore"
            8 arch="noarch"
            9 license="Apache-2.0"
           10 _py2_deps="py2-pbr"
           11 _py3_deps="py3-pbr"
           12 makedepends="$_py2_deps $_py3_deps python2-dev python3-dev py-setuptools"
           13 subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
           14 source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
           15 builddir="$srcdir/$_pkgname-$pkgver"
           16 
           17 build() {
           18         cd "$builddir"
           19 
           20         python2 setup.py build || return 1
           21         python3 setup.py build || return 1
           22 }
           23 
           24 package() {
           25         mkdir -p "$pkgdir"
           26 }
           27 
           28 _py2() {
           29         replaces="$pkgname"
           30         _py python2
           31 }
           32 
           33 _py3() {
           34         _py python3
           35 }
           36 
           37 _py() {
           38         local python="$1"
           39         pkgdesc="$pkgdesc (for $python)"
           40         depends="$depends $python"
           41         install_if="$pkgname=$pkgver-r$pkgrel $python"
           42 
           43         cd "$builddir"
           44         $python setup.py install --prefix=/usr --root="$subpkgdir"
           45 }
           46 
           47 sha512sums="3316ba9c73dc5499588a65fb0abc85ffc8eeea14dc94fbaced6379246098f03201d8a13dc64510a0840cb3d266ac83ffbb957738a61ee2a36440611833bab4ef  stevedore-1.30.1.tar.gz"