tAPKBUILD - paraports - parazyd's aports
 (HTM) git clone https://git.parazyd.org/paraports
 (DIR) Log
 (DIR) Files
 (DIR) Refs
 (DIR) README
 (DIR) LICENSE
       ---
       tAPKBUILD (1518B)
       ---
            1 # Maintainer: Ivan J. <parazyd@dyne.org>
            2 pkgname=py-subliminal
            3 _pkgname=subliminal
            4 pkgver=2.0.5
            5 pkgrel=0
            6 pkgdesc="Subtitles, faster than your thoughts"
            7 url="https://github.com/Diaoul/subliminal"
            8 arch="noarch"
            9 license="MIT"
           10 _py2_deps="py2-appdirs py2-babelfish py2-beautifulsoup4 py2-chardet py2-click py2-decorator py2-dogpile-cache py2-enzyme py2-guessit py2-pysrt py2-pytz py2-rarfile py2-requests py2-six py2-stevedore py2-future"
           11 _py3_deps="py3-appdirs py3-babelfish py3-beautifulsoup4 py3-chardet py3-click py3-decorator py3-dogpile-cache py3-enzyme py3-guessit py3-pysrt py3-pytz py3-rarfile py3-requests py3-six py3-stevedore py3-future"
           12 makedepends="$_py2_deps $_py3_deps python2-dev python3-dev py-setuptools"
           13 subpackages="py2-${pkgname#py-}: py2 py3-${pkgname#py-}:_py3"
           14 source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
           15 builddir="$srcdir/$_pkgname-$pkgver"
           16 
           17 build() {
           18         cd "$builddir"
           19 
           20         python2 setup.py build || return 1
           21         python3 setup.py build || return 1
           22 }
           23 
           24 package() {
           25         mkdir -p "$pkgdir"
           26 }
           27 
           28 _py2() {
           29         replaces="$pkgname"
           30         _py python2
           31 }
           32 
           33 _py3() {
           34         _py python3
           35 }
           36 
           37 _py() {
           38         local python="$1"
           39         pkgdesc="$pkgdesc (for $python)"
           40         depends="$depends $python"
           41         install_if="$pkgname=$pkgver-r$pkgrel $python"
           42 
           43         cd "$builddir"
           44         $python setup.py install --prefix=/usr --root="$subpkgdir"
           45 }
           46 
           47 sha512sums="56bc0e87496d5bc361430c4ee396b20374da697014203bdc4dda12341918e67c98aec579e44bd467898dbbf11f31e9de47ece17a0d78339f2bc700e3e6c8dd40  subliminal-2.0.5.tar.gz"