libbitcoin-server-9999.ebuild - parlay - yet another gentoo overlay
 (HTM) git clone https://git.parazyd.org/parlay
 (DIR) Log
 (DIR) Files
 (DIR) Refs
 (DIR) README
       ---
       libbitcoin-server-9999.ebuild (680B)
       ---
            1 # Copyright 1999-2022 Gentoo Authors
            2 # Distributed under the terms of the GNU General Public License v2
            3 
            4 EAPI=8
            5 
            6 inherit autotools git-r3
            7 
            8 DESCRIPTION="Bitcoin full node and query server"
            9 HOMEPAGE="https://libbitcoin.info"
           10 EGIT_REPO_URI="https://github.com/libbitcoin/${PN}"
           11 
           12 LICENSE="AGPL-3+"
           13 SLOT="0"
           14 KEYWORDS="~amd64 ~x86"
           15 IUSE="static-libs debug test"
           16 
           17 DEPEND="
           18         >=dev-libs/boost-1.72.0:=[threads(+)]
           19         >=net-p2p/libbitcoin-node-${PV}
           20         >=net-p2p/libbitcoin-protocol-${PV}
           21 "
           22 RDEPEND="${DEPEND}"
           23 
           24 src_prepare() {
           25         eautoreconf
           26         default
           27 }
           28 
           29 src_configure() {
           30         econf \
           31                 --with-console \
           32                 $(use_with test tests) \
           33                 $(use_enable static-libs static) \
           34                 $(use_enable debug ndebug)
           35 }