ttorbrowser-launcher-9999.ebuild - parlay - yet another gentoo overlay
 (HTM) git clone https://git.parazyd.org/parlay
 (DIR) Log
 (DIR) Files
 (DIR) Refs
 (DIR) README
       ---
       ttorbrowser-launcher-9999.ebuild (1254B)
       ---
            1 # Copyright 1999-2021 Gentoo Authors
            2 # Distributed under the terms of the GNU General Public License v2
            3 
            4 EAPI=7
            5 
            6 PYTHON_COMPAT=( python3_{7,8,9} )
            7 
            8 inherit distutils-r1 xdg
            9 
           10 DESCRIPTION="A program to download, updated, and run the Tor Browser Bundle"
           11 HOMEPAGE="https://github.com/micahflee/torbrowser-launcher"
           12 
           13 if [[ "${PV}" == *9999* ]]; then
           14         inherit git-r3
           15         EGIT_REPO_URI="https://github.com/micahflee/${PN}.git"
           16 else
           17         SRC_URI="https://github.com/micahflee/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
           18         KEYWORDS="~amd64"
           19 fi
           20 
           21 RESTRICT="test"
           22 LICENSE="MIT"
           23 SLOT="0"
           24 IUSE="apparmor"
           25 
           26 RDEPEND="
           27         app-crypt/gpgme[python,${PYTHON_USEDEP}]
           28         dev-python/PyQt5[${PYTHON_USEDEP},widgets]
           29         dev-python/PySocks[${PYTHON_USEDEP}]
           30         dev-python/requests[${PYTHON_USEDEP}]
           31         dev-python/packaging[${PYTHON_USEDEP}]
           32         apparmor? ( sys-libs/libapparmor )
           33 "
           34 
           35 PATCHES=(
           36         "${FILESDIR}/${PN}-distro.patch"
           37 )
           38 
           39 python_install_all() {
           40         distutils-r1_python_install_all
           41 
           42         # delete apparmor profiles
           43         if ! use apparmor; then
           44                 rm -r "${D}/etc/apparmor.d" || die "Failed to remove apparmor profiles"
           45                 rmdir "${D}/etc" || die "Failed to remove empty directory"
           46         fi
           47 }
           48 
           49 pkg_postinst() {
           50         xdg_pkg_postinst
           51 
           52         elog "For updating over system TOR install net-vpn/tor and dev-python/txsocksx"
           53 }